Etherchannel Example

Cisco Etherchannel Configuration Example

Description:
The following is a basic example of an etherchannel on a Cisco IOS device. Etherchannels (sometimes referred to as port channels, or channel groups) are a way to combine multiple ports on a switch to allow you to use the bandwidth from all connections as one. This means if you channel 2 Gig ports, you have 2GB of throughput. The bandwidth depends on the kind of ports and number you bundle together. Some uses would include increasing throughput between switch trunks, or even bundling ports that connect to a server that can handle 802.1q trunking on it’s own. This would allow setup of ESX virtual switches for Virtual Machines. Regardless of your use, you can configure a Layer 2 or Layer 3 etherchannel, both examples are listed below. Choose whichever fits your needs and customize it accordingly. Ensure that the other side of your port-channel’s configuration matches exactly in order for the etherchannel to sync up.

[divider]
[tabs]

[tab title=”View Configuration”]
View the configuration:


! LAYER 2 PORT CHANNEL
! Configuring the actual port-channel to assign ports to.
interface port-channel 2
description Layer 2 Port-Channel
switchport mode trunk
switchport trunk native vlan 50
! Set what vlans should be allowed over the etherchannel, just like a regular trunk.
switchport trunk allowed vlan 5,10,15,50
!!!!!
! Now configure the ports you want to be in the port-channel
interface range Gig0/1-4
switchport mode trunk
switchport trunk native vlan 50
switchport trunk allowed vlan 5,10,15,50
! The following line is key to ensuring the ports specified are in the port-channel.
channel-group 2 mode active
!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!
! LAYER 3 PORT CHANNEL
! Configuring the actual port-channel to assign ports to.
interface port-channel 3
description LAYER 3 Port-Channel
no switchport
ip address 10.0.0.1 255.255.255.252
!!!!!
! Now configure the ports you want to be in the port-channel
interface range Gig0/1-4
no switchport
channel-group 3 mode active

[/tab]

[tab title=”Edit Configuration”]
Edit and Use:

[/tab]

[tab title=”Show Commands”]

  • show etherchannel summary
  • show etherchannel port-channel

[/tab]
[/tabs]

[button color=”blue” size=”medium” align=”center” style=”lessround” target=”_blank” link=”http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3550/software/release/12-2_44_se/configuration/guide/3550SCG/swethchl.html” ]View More Documentation[/button]

Google+ Linkedin

Leave a Reply

Your email address will not be published. Required fields are marked *

*
*
*